Update Rolling out

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Jan 29, 2024 - 20:06 UTC

Investigating

There may be some issues joining servers as we restart them to apply a new update.
Posted Jan 29, 2024 - 19:56 UTC
This incident affected: Game API.