Issues with Multiplayer

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Sep 25, 2024 - 01:27 UTC

Update

We are continuing to investigate this issue.
Posted Sep 25, 2024 - 01:26 UTC

Investigating

Currently looking at a connection issue with servers.
Posted Sep 25, 2024 - 00:48 UTC
This incident affected: Game API.