Issues with Logging into Servers & Server List

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Jan 07, 2024 - 22:25 UTC

Investigating

We are having some performance issues with our Server API which is leading to issues logging in and loading the server list. We are working on a fix.
Posted Jan 07, 2024 - 18:53 UTC
This incident affected: Game API.