Login / Server Issues

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 03:47 UTC

Investigating

We are currently investigating this issue.
Posted Apr 21, 2025 - 02:51 UTC
This incident affected: Game API.