Issues with Matchmaking

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted May 10, 2024 - 22:55 UTC

Identified

Currently looking into issues with Matchmaking Servers.
Posted May 10, 2024 - 21:43 UTC
This incident affected: Game API.