Issues with Matchmaking / Server Crashes

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Jan 04, 2024 - 23:43 UTC

Investigating

We are looking into a player reported issue about matchmaking / server crashes.
Posted Jan 04, 2024 - 21:09 UTC
This incident affected: Game API.