Matchmaking Issues for Official Servers

Incident Report for Alderon Games

Resolved

The issue has been fixed.
Posted Jun 20, 2024 - 03:25 UTC

Investigating

Players are experiencing issues loading into matchmaking servers and long matchmaking times.
Posted Jun 20, 2024 - 03:03 UTC
This incident affected: Game API.