Issues joining Official Servers

Incident Report for Alderon Games

Resolved

Matchmaking issue appears to be resolved and is working again in our tests.
Posted Apr 18, 2024 - 23:56 UTC

Investigating

Looking into why users are sometimes unable to join Official Servers via Matchmaking
Posted Apr 18, 2024 - 22:39 UTC
This incident affected: Game API.