Known Server Issues

Incident Report for Alderon Games

Resolved

Seems to be operational now. Let us know if you have any issues.
Posted Mar 29, 2025 - 20:43 UTC

Investigating

Currently working on a fix.
Posted Mar 29, 2025 - 20:30 UTC
This incident affected: Game API.