Known Server Issues

Incident Report for Alderon Games

Resolved

Servers currently working.
Posted Mar 16, 2025 - 20:46 UTC

Investigating

We are currently investigating. There seems to be a issue with servers having problems once or twice a day past few days.
Posted Mar 16, 2025 - 20:17 UTC
This incident affected: Game API.